WordPress auto Update – Wenn es mal nicht funktioniert

Wordpress

WordPress auto Update – Wenn es mal nicht funktioniert

WordPress auto Update – Wenn es mal nicht funktioniert

Bis gestern wusste ich die Auto-Update Funktion von WordPress 2.7 sehr zu schätzen. Eigentlich auch nur aufgrund Ihrer Anwesenheit, den getestet hatte ich sie bisher nicht. Was soll schon dabei schief gehen?

Verkürzt ausgedrückt: Eine Menge. Denn diese Funktion reagiert sehr empfindsam auf etwas das aus der Windows-Welt eher unbekannt ist: Dateisystemberechtigungen. Zunächst passierte bei Update der Plugins einfach gar nichts bzw. nur wenig. Lade Datei xyz von update… herunter. Das wars. Irgendwie traurig, dachte ich mir und schaute mal in die Verzeichnisberechtigungen. Das Ergebnis war irritierend: das für Plugins relevante Verzeichnis wp-content gehörte meinem Systembenutzer, aber nicht seiner Gruppe (www). Dies sollte meinem Verständnis folgend eigentlich kein Problem sein. Schließlich dürfte das einer der Gründe dafür sein, warum bei automatischen Update einen Benutzernamen und ein Kennwort eingeben muss: Damit der Update-Meschanismus mit den richtigen Berechtigungen auf dem Dateisystem schreiben kann. Tut er aber offenbar nicht. Denn als ich das Verzeichnis mittels chown der richtigen Gruppe zuordnete verlief der Auto-Update mechanismus ohne Probleme.

Vor einer Sache möchte ich jedoch eindringlich warnen:

Dem automatischen Update des Plugins wp-super-cache. Dieses Plugin ist zwar extrem nützlich um die Performance von WordPress zu steigern. Dummerweise legt es aber mehrere Dateien und Verzeichnisse an. Hat davon auch nur eines die falsche Berechtigung scheitert das Update, und WordPress liefert fortan nur noch weiße Seiten. Das hilft auch eine manuelle Deaktivierung nichts. Wie man ein Plugin manuell deaktiviert, habe ich kürzlich hier beschrieben.

Diskussion

2 Kommentare zu “WordPress auto Update – Wenn es mal nicht funktioniert”

  1. Danke für deinen Artikel. Ich mache grundsätzlich keine automatischen Updates, ich bin froh wenn eine Version fehlerfrei mit den Plugins funktioniert. Da bastle ich lieber nicht daran herum. :)
    lg

    Posted by Georg | August 16, 2010, 13:03
  2. Bei mir liegt es am fehlenden Arbeitsspeicher des Webhosters. Nach vorübergehender Deaktivierung der Plugins funktioniert alles Bestens!

    Posted by Bernhard vom TV Ebern | April 23, 2012, 15:03

Post a comment